Enable button of staking creth

the button is not function for the whole day

Which wallet and/or browser do you use? On mobile or desktop?

1 Like

using argent, but long time no response from ur own team

It works for me. I can connect to Argent via WalletConnect.

Do you have any ETH in your wallet balance? If yes, did you try to put number first in the input field?
A friendly reminder: you don’t need to enable ETH on Ethereum Mainnet, for it’s native token.